Xcode新版本找不到Application Loader,改用Transporter

前几天把MacBook里的Xcode升级了,升级到11.2版本后,发现没得Application Loader工具了。我用APICloud生成ipa包,顿时不知道怎么上传给AppStore了。

后面通过查询资料得知,有5种解决方法:

一,给Xcode降级,然后就会有自带的Application Loader工具了。

二,下载Application Loader插件,装在Xcode目前的版本上。

三,直接通过通过Xcode上传ipa,有教程:https://help.apple.com/xcode/mac/current/#/dev442d7f2ca

四,通过altool上传ipa。使用xcrun(包含在 Xcode 中)来调用altool,该命令行工具用于公证、验证并上传ipa到AppStore。altool教程:https://help.apple.com/asc/appsaltool/

五,通过Transporter应用上传ipa。Transporter是苹果新推出的应用,这是我最终选择的方式,也是我最推荐的方式,特别是我们这种通过其他工具编译出的ipa文件。

打开MacBook笔记本里的AppStore应用市场,搜索“Transporter”,下载安装。Transporter的使用比Application Loader工具更加简单好用,强烈推荐。

Transporter.jpg

添加新评论